Tag Archives: 升级

CentOS 5.5用yum无法升级到php5.2.x的问题

有一个破服务器装了64位的Cent OS 5.5,用yum安装php,版本是5.1.6的.
现在程序大多需要5.2.x,用常规的yum update php根本不能更新,5.1.6是centos官方的最新版了似乎(擦,为啥不更新新点的啊)
在网上找了两个方法都无法正确升级.最后Google到一个能升级到5.2的办法,不过是半官方的- CentOS-Testing.
方法:

1.编辑/etc/yum.repos.d/CentOS-Base.repo,再最后加入下列内容在保存

[c5-testing]
name=CentOS-5 Testing
baseurl=http://dev.centos.org/centos/$releasever/testing/$basearch/
enabled=0
gpgcheck=1
gpgkey=http://dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing

2.然后其他源停用,就用CentOS-Testing来搜索php的更新.

yum --disablerepo=* --enablerepo=c5-testing check-update php*

3.接着就展示出一堆稀里哗啦的更细,泪奔.注意看,是不是都是php-xxx 5.2.x c5-testing这样东西.

4.如果没有问题,那么just do it…

yum --disablerepo=* --enablerepo=c5-testing update php*

装完后php -v看一样版本是不是5.2.x了?嗯,到时候跑的时候记得重启apache.

WordPress 2.1 Release Candidate 1

WordPress 2.1版本升级最近是出奇的快.前日还是beta4的,18号就出RC1了.不过没什么大变动.估计出到RC3就是release版了.

On 1/18/07, Ryan Boren wrote:
>
> http://wordpress.org/beta/wordpress-2.1-RC1.zip
>
> Changes since beta4 include send to editor, thumbnailing, pingback, and
> autosave fixes. Things to test:
>
> * Incoming and outgoing pingbacks
> * Image uploader. Particularly thumbnailing and send to editor.
> * Autosave. Try publishing directly prior to and after autosave kicks in.
> autosave happens every two minutes.
>
> Ryan

顺便提下,用148.233.159.58:3128这个代理访问国外网站嗷嗷快啊!